[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Condor-users] Question regarding my approach in -->Re: Master won't start


I tried to work around the same problem by copying condor_configure file to condor user home directory.

I am afraid i cannot continue with this approach for long time as, if i change any environment variables values of condor_configure in future, then there might be inconsistency between condor_configure file <release dir>/etc/ and the condor_configure file from home/condor/ dir.

Any suggestions to me please? i appreciate your time and effort to help me.


Erik Paulson <epaulson@xxxxxxxxxxx> wrote:
On Wed, Mar 08, 2006 at 04:23:37PM -0500, Steve Huston wrote:
> We ran Condor awhile ago and turned it off while we did some changes,
> and now I'm setting it up again. I've got a Fedora 3 machine (quad
> Opteron) which I'm setting up with Condor 6.7.! 17, and every time I run
> it I get the following error:
> Neither the environment variable CONDOR_CONFIG,
> /etc/condor/, nor ~condor/ contain a condor_config file.
> Either set CONDOR_CONFIG to point to a valid config file,
> or put a "condor_config" file in /etc/condor or ~condor/
> There *is* a condor_config file in ~condor/ and this is the same setup
> we used before with the previous machines (though I edited the file so
> it reflects the new setup, and new options since this is also a newer
> version of the software). If I do as it says and set an environment
> variable, I instead get the following:
> ERROR: the uid specified in CONDOR_IDS config file variable (9016)
> does not exist in your password information.
> Please set CONDOR_IDS to the '.' seperated uid, gid pair that
> should be used by condor.
> Our authentication is done via LDAP, ! but the UID 9016 does in fact match
> the condor user. All the files are owned by the condor user as well.

Is your config file in NFS? Do you have root squash turned on?

> If I instead run the daemon as root (which is what I want to do), I get
> the "no config" error no matter what, even if I set the environment
> variable - *except* if I try to run it through gdb, then I get the "no
> UID" error. I hoped that there'd be some debugging in the binaries,
> which is how I found the difference running through gdb.
> I've attached an strace of the process if it will help someone, but I
> don't see where it even tries to look up anything to determine that
> there is no file in ~condor, nor does it look in /etc/condor. This
> trace was when running it as root.

The master forks and goes into the background, and the process that
looks for the config file is the forked child. Run th! e master with
the '-f' flag:

strace condor_master -f

to get a better trace.

Condor-users mailing list

Brings words and photos together (easily) with
PhotoMail - it's free and works with Yahoo! Mail.