[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] Master won't start

On Thu, Mar 09, 2006 at 03:50:32PM -0500, Steve Huston wrote:
> On 2006/03/09 12:55, Erik Paulson wrote:
> > Is your config file in NFS? Do you have root squash turned on?
> Yes, and yes.  All owned by the condor user and world readable.
> ~condor/condor_config is a symlink to ~condor/etc/condor_config.  This
> is how we had it setup on the other machine which was the master; the
> only differences are the architecture, the OS version (RH9 vs FC3) and
> the fact that before we were running NIS, now we use LDAP.
> > The master forks and goes into the background, and the process that
> > looks for the config file is the forked child. Run the master with
> > the '-f' flag:
> > strace condor_master -f
> > to get a better trace.
> Tried that and got the same error, and same output, as before.

I'm a bit confused - I don't see any output from the
write() system call to even print an error message, and 
it's dying in umask(). 

Just to make it explicit, can you send the complete
transcript of 
strace -o /some/path/to/a/traceefile condor_master -f -t

as well as the output from condor_master (if any)

Similiarly, can you also try 

strace -o /some/path/to/a/tracerfile2 condor_config_val -verbose LOG
(or some other setting you know must be there)