[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] Trouble communicating through GCB servers


Thanks for the replies everyone!

I've been experimenting some more with GCB, but still no success.
I Now have the most basic setup I could think of to test GCB. This setup
consists of two private networks connected by a router. One network
connected to the WAN-side and the other to the LAN-side, so both
networks have different IP ranges.

See this picture for details:

Each network has one GCB server and one Condor system (one client in
network A and a central manager in network B).
Only the GCB-servers are told that there is a gateway (router), so they
can talk to each other perfectly. The Condor systems do not know the
route to each other or to the GCB server from the other private network
(as it will be in a real-world situation where nodes cannot see each
other directly).

I told both Condor systems to use the GCB-server within their own
private network (in condor_config.local) I believe this works fine,
since for example the MasterLog from 'condor client #1' shows this line
at startup: "DaemonCore: Command Socket at <>" which
is the address of the GCB-server. But there isn't any traffic between
both GCB-servers. The central-manager is communicating through GCB
(while contacting it's own collector...) but the condor client cannot
contact the manager.

My guess is that it has something to do with the routing tables for GCB.
I've tried a number of settings, but it didn't help. It did change some
of the errors the condor client gave me. Examples of the errors I get:

- "GCB: ERROR "GCB_TCP_connect: connection to the dest broker failed"
errno 101: network is unreachable"
- "GCB: [GCB_connect(12)]<>: direct connect using
_CB_do_connect failed"
- "GCB: ERROR "GCB_TCP_connect: connection to the dest broker failed"
errno 101: network is unreachable"

The gcb route table looked like this:  GCB   # public IP for GCB #2   GCB   # local GCB server

I use ethereal on GCB#2 to scan for any incoming traffic from the .20.*
network, but nothing comes through..

Can anyone help me constructing a gcb routing table?

Many thanks, and sorry for the long story once again...

Marcel Kempenaar