[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] Condor birdbath problems

The NoSuchMethodError is usually an indication that you are trying to connect to an endpoint (e.g. http://localhost:9618) that does not implement the interface you are expecting (e.g. ...:9618 probably implements the Collector API, but not the Schedd).

If you want to query for a Schedd address you'll need to connect to a Collector (likely port 9618, the default). Once you get the Schedd address you need to make sure you connect to it and not the Collector again.



Christopher Parker wrote:

I have compiled the java files which I generated from the WDSLs for the
Schedd and the Collector by using Apache Axis 1.4. I have tried to use these
files to submit a job to condor and it worked, however, when I try to obtain
the address of the scheduler by using the collector, I got strange errors.
This prompted me to try the gr-wscondor jar provided by IBM. This fixed the
problem with getting the address of the scheduler. Now, when I try to submit
a file as I did when I compiled the files myself, I get the following error:

Exception in thread "main" java.lang.NoSuchMethodError:
        at birdbath.Transaction.submit(Transaction.java:127)
        at condor.main(condor.java:223)

Does anyone know how to fix this? I am using Java 1.5.0_08-b03 and as
mentioned already Axis 1.4 - the latest version. Also, when I compile using
the Axis jars some files are not created and hence not compiled. Am I using
the correct versions of Axis / Java or is this perhaps an OS specific error?


Christopher Parker (BSc. Hons)
Department of Computer Science
High Performance Computing Laboratory
University of Cape Town

Condor-users mailing list
To unsubscribe, send a message to condor-users-request@xxxxxxxxxxx with a
subject: Unsubscribe
You can also unsubscribe by visiting

The archives can be found at: https://lists.cs.wisc.edu/archive/condor-users/