[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] Problem with Condor standalone library

Hi Daniel,
 Thank you for your suggestion. Well, I just tried now with setting arch, but still it takes myapp.ckpt.tmp. So that means
the checkpoint is not successful. The kind of application I am running is a very simple helloworld application. that waits for sometime and
prints a value. so, type of application is not the problem. Moreover, I have also tried to send USR2 from another terminal,
but still the chekcpoint taken is a .tmp file. What do you think could be causing this problem?

- Tan

On Sat, Mar 22, 2008 at 1:45 PM, Daniel Forrest <forrest@xxxxxxxxxxxxx> wrote:
Hi Tan,

> I have been trying to checkpoint one of my applications using condor's
> standalone library. What I am doing is:
> condor_compile gcc myapp.c -o myapp
> ./myapp

Try running it this way:

setarch i386 -R ./myapp

> then, when I am trying to restart the process by writing -
> ./myapp -_condor_restart myapp.ckpt.tmp

The fact that the checkpoint file has ".tmp" at the end is a sign that
the checkpoint was not successful.  If the previous suggestion worked,
you will also want to restart like this:

setarch i386 -R ./myapp -_condor_restart myapp.ckpt

> And another question is how to send SIGUSR2 signal , I mean CTRL-?

As far as I know, you need to "kill -USR2 <pid>" from another terminal.

Daniel K. Forrest       Laboratory for Molecular and
forrest@xxxxxxxxxxxxx   Computational Genomics
(608) 262 - 9479        University of Wisconsin, Madison

Tanzima Zerin Islam