[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] REQUIRE_LOCAL_CONFIG_FILE = False usage problem

kschwarz@xxxxxxxxxxxxxx wrote:

Hi all,

I am using Condor v7.2.4, Windows, and I am testing REQUIRE_LOCAL_CONFIG_FILE = False. I am trying to define a default configuration file in a shared filesystem while a host specific config file does not exist, both files referenced in the host local config file.

When local Config file is as follow:

myshareserver  = SMBSJK21
        $(LOCAL_CONFIG_FILE), \
\\$(myshareserver)\grid_env\CONDOR\1-start\condor_config.master.DEFAULT, \ \\$(myshareserver)\grid_env\CONDOR\1-start\condor_config.master.$(HOSTNAME)

and the last referenced file does not exist, Condor does not start because it could not find that file. When I execute any Condor command they give an error message saying that that file was not found.

ERROR: Can't read config source \\SMBSJK21\grid_env\CONDOR\1-start\condor_config.master.PC303344

REQUIRE_LOCAL_CONFIG_FILE is supposed to avoid this problem, correct?!


How could I fix it?

FWIW, I just tried to reproduce the problem you describe above (albeit using a more current release of Condor), and failed to do so. REQUIRE_LOCAL_CONFIG_FILE worked as expected w/ Condor v7.5.x, and nothing in the version history or source repository lead me to think there was some bug with this functionality back w/ v7.2.x.

Are you sure the primary config file on the machine were you ran condor_status has "REQUIRE_LOCAL_CONFIG_FILE = False" ? I.e. you didn't just make this edit on the config file on your central manager?