[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] REQUIRE_LOCAL_CONFIG_FILE = False usage problem


Answering your questions:

>Are you sure the primary config file on the machine were you ran
>condor_status has "REQUIRE_LOCAL_CONFIG_FILE = False" ? I.e. you didn't
>just make this edit on the config file on your central manager?

Yes, I am sure. My CM is another machine. The configuration files I am changing is local condor_config.local of my personal machine.

Find attached the primary config file I am using. REQUIRE_LOCAL_CONFIG_FILE is commented (line 71), so it is assuming REQUIRE_LOCAL_CONFIG_FILE=True (as described in the documentation). After reading this file, it reads condor_config.local file (with the settings I submitted, an have also attached). The attached file is a Zip file, please change the file extension.


Todd Tannenbaum <tannenba@xxxxxxxxxxx>
Sent by: condor-users-bounces@xxxxxxxxxxx

30/08/2010 12:29

Please respond to
Condor-Users Mail List <condor-users@xxxxxxxxxxx>

Condor-Users Mail List <condor-users@xxxxxxxxxxx>
Re: [Condor-users] REQUIRE_LOCAL_CONFIG_FILE = False usage problem

kschwarz@xxxxxxxxxxxxxx wrote:
> Hi all,
> I am using Condor v7.2.4, Windows, and I am testing
> I am trying to define a default configuration file in a shared
> filesystem while a host specific config file does not exist, both files
> referenced in the host local config file.
> When local Config file is as follow:
> myshareserver  = SMBSJK21
> #
>         $(LOCAL_CONFIG_FILE), \
> \\$(myshareserver)\grid_env\CONDOR\1-start\condor_config.master.DEFAULT, \
> \\$(myshareserver)\grid_env\CONDOR\1-start\condor_config.master.$(HOSTNAME)
> and the last referenced file does not exist, Condor does not start
> because it could not find that file.
> When I execute any Condor command they give an error message saying that
> that file was not found.
> C:\Users\kschwarz>condor_status
> ERROR: Can't read config source
> \\SMBSJK21\grid_env\CONDOR\1-start\condor_config.master.PC303344
> REQUIRE_LOCAL_CONFIG_FILE is supposed to avoid this problem, correct?!


> How could I fix it?

FWIW, I just tried to reproduce the problem you describe above (albeit
using a more current release of Condor), and failed to do so.
REQUIRE_LOCAL_CONFIG_FILE worked as expected w/ Condor v7.5.x, and
nothing in the version history or source repository lead me to think
there was some bug with this functionality back w/ v7.2.x.

Are you sure the primary config file on the machine were you ran
condor_status has "REQUIRE_LOCAL_CONFIG_FILE = False" ?  I.e. you didn't
just make this edit on the config file on your central manager?


Condor-users mailing list
To unsubscribe, send a message to condor-users-request@xxxxxxxxxxx with a
subject: Unsubscribe
You can also unsubscribe by visiting

The archives can be found at:

This message is intended solely for the use of its addressee and may contain privileged or confidential information. All information contained herein shall be treated as confidential and shall not be disclosed to any third party without Embraer’s prior written approval. If you are not the addressee you should not distribute, copy or file this message. In this case, please notify the sender and destroy its contents immediately.
Esta mensagem é para uso exclusivo de seu destinatário e pode conter informações privilegiadas e confidenciais. Todas as informações aqui contidas devem ser tratadas como confidenciais e não devem ser divulgadas a terceiros sem o prévio consentimento por escrito da Embraer. Se você não é o destinatário não deve distribuir, copiar ou arquivar a mensagem. Neste caso, por favor, notifique o remetente da mesma e destrua imediatamente a mensagem.

Attachment: condor_config_files.zi_
Description: Binary data