[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Condor-users] Inconsistent Disappearing Backslashes in Windows UNC Paths for Output and Error Lines


I am experiencing some very frustrating problems with how Condor is
interpreting my output and error lines.

I believe it first happened after upgrading to Condor version 7.8.0.
I found my shadow log was turning double backslashes ("\\") into
single backslashes, and single backslashes were just removed.  (These
paths are UNC path's, e.g. \\10.75.x.x\somedir\.)  Accordingly, I
doubled every backslash in the output and error lines of my submit
file, and everything worked as expected (e.g. output =

Later, we sent our program out the door to someone who was running
7.8.3, and their system had trouble with the double backslashes..
They switched these to single backslashes and it worked as expected.
2 months later, on the same exact system but a new program, they are
now having the original problem I had and double backslashes are the
only things that make it work!

I have looked high and low for the reason why this is happening but I
can't find anything.  It is extremely frustrating, since it seems to
be somewhat random (they are two different submit files, but they seem
to have the same exact format).

Any help/clues would be greatly appreciated!