[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[HTCondor-users] Missing stdout/stderr logfile group write permission

Hello all,
below I cite rrom a mail found in the archive which unfortunately was unanswered then. I am just running into similar problems.

I am running Condor 7.0.1 as user "condor" with group "condor". I have
setgid condor on the condor_submit executable. When I submit a job as
user "juve", the output and error files are created with the correct
permissions, but the log file is created without group write
permissions. This prevents Condor from writing updates to my log file,
which causes the job to hang.

Here's my test job:

universe = local
executable = /bin/date
transfer_executable = false
output = test_$(cluster).$(process).out
error = test_$(cluster).$(process).err
log = test_$(cluster).$(process).log
notification = NEVER
queue 1

Here is the (partial) output of "ls -al" after I condor_submit the job:

-rw-rw-r-- 1 juve condor   0 2008-10-24 16:57 test_6.0.err
-rw-r--r-- 1 juve condor  84 2008-10-24 16:57 test_6.0.log
-rw-rw-r-- 1 juve condor   0 2008-10-24 16:57 test_6.0.out

Does anyone know why Condor isn't setting g+w on the log file?

Thank you,

First of all: My data are on an NFS shared location, logfiles are also targeted there. I am submitting my jobs as user "felix", actually planned remotely but to break down the problem locally at the moment.

The only difference here to the descrption above is, that I am running condor (7.6.8) as condor:users and submitting simple vanilla universe job works. But I have to do a dag. So (for some other reasons) I run condor_submit_dag -no_submit myDagFile.sub and then using condor_submit with the generated myDagFile.dag.sub.condor.sub - this fails cause the stdout/stderr logfiles have the submitting user as owner and get generated with rw r r, thus making the actuall execution which runs under a special execution accout, fail on writing to that logfile.

To avoid that I allready use the same group "users" for any involved user. Umask is set to 0002 everywhere per user as well as globally.

I just do not understand, why this logfile is generated not group-writable. This is also the case for the .dag.sub.lock and dag.sub.dagman.out files. I also tried setgid on condor_submit, condor_submit_dag and, more important condor_dagman - with no success.

For now I am not yet attaching any submission files, for I do not see any setting there related to that problem.