[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [HTCondor-users] subject: install HTCondor 8.4.0-1 on RHEL 6.2 libcrypto.so.10 error

Maybe a newbie Linux question more than a Condor question but I am still having the same error this time it's on RHEL 7.1. Here is the error I am getting after running "yum install condor.x86_64".

And I am on the latest version of OpenSSL.

--> Processing Dependency: libpcre.so.0()(64bit) for package: condor-classads-8.4.1-1.el6.x86_64
---> Package perl-IO-Zlib.noarch 1:1.10-285.el7 will be installed
---> Package perl-Package-Constants.noarch 1:0.02-285.el7 will be installed
--> Finished Dependency Resolution
Error: Package: condor-8.4.1-1.el6.x86_64 (htcondor-stable)
     ÂRequires: ecryptfs-utils
Error: Package: condor-classads-8.4.1-1.el6.x86_64 (htcondor-stable)
     ÂRequires: libpcre.so.0()(64bit)
Error: Package: condor-8.4.1-1.el6.x86_64 (htcondor-stable)
     ÂRequires: libpcre.so.0()(64bit)
ÂYou could try using --skip-broken to work around the problem
ÂYou could try running: rpm -Va --nofiles --nodigest



On Wed, Oct 7, 2015 at 1:29 PM, Michael V Pelletier <Michael.V.Pelletier@xxxxxxxxxxxx> wrote:
Hi Jon,

I ran into this myself last year under RHEL 6.4. I think the issue is that the newer UW build was compiled against OpenSSL 1.0.1 in the wake of the HeartBleed bug, and while that bug doesn't affect the 6.0 through 6.4 OpenSSL 1.0.0 series, I think the linker is still looking for the 1.0.1 release. I think if you upgrade your OpenSSL package to 1.0.1e-42, which is the current release for RHEL6, that should satisfy the dependencies. See step 3 at https://access.redhat.com/solutions/781793

Or better yet, just patch your systems to 6.7. There's gobs of improvements in the intervening releases, including noticeable performance increases that will improve your pool. Remember, the Red Hat minor releases are essentially patch bundles like the old Solaris Recommended & Security bundles, as opposed to the gulf you find between SunOS 5.9 and 5.10 "minor" release numbers. IT management should be focused on the "6," not the ".2" or the ".7" numbers, and errata should be applied on a regular basis.

That said, though, you should also make sure your various firmware and BIOS versions are up to date beforehand - a certain HP Ethernet card won't work if you go to 6.5 or higher without new enough firmware on it, for example, and that's a real hassle when you have a diskless node.


Michael V. Pelletier
IT Program Execution
Principal Engineer
978.858.9681 (5-9681) NOTE NEW NUMBER
339.293.9149 cell
339.645.8614 fax


HTCondor-users mailing list
To unsubscribe, send a message to htcondor-users-request@xxxxxxxxxxx with a
subject: Unsubscribe
You can also unsubscribe by visiting

The archives can be found at: