[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [HTCondor-users] UNC and mapped drive misunderstanding (not blocking issue)

Perhaps you could try using cmd.exe as your executable?

Executable = cmd.exe
Arguments = /U /Q /C \\\\\\Share\\test_condor\\job.bat 
Transfer_executable = false

-----Original Message-----
From: HTCondor-users [mailto:htcondor-users-bounces@xxxxxxxxxxx] On Behalf Of Mathieu PeyrÃga
Sent: Thursday, January 21, 2016 3:16 AM
To: htcondor-users@xxxxxxxxxxx
Subject: Re: [HTCondor-users] UNC and mapped drive misunderstanding (not blocking issue)

thanks for the URL,

i'll try the registry setting and let you know.

as for the codepage issue, I've tryied 2 things :

getenv = True in the submit file

using the CHCP command in my wrapper batch file with various codepages
(850 as set by default here, 1252 and 437 for trials)

none solve the accents issues.

I guess it may be solved by adding /A ou /U to the cmd.exe process

the current line spawned by HTCondor as reported in StartLog.slotN files is looking like :

01/21/16 10:06:17 (pid:10816) Executable is a batch file, running:
"C:\windows\system32\cmd.exe" /Q /C
"\\\Share\test_condor\job.bat" laszip.exe -i \\\Share\test_condor\1622000_9310000.las

probably this CHCP command should be set before calling cmd.exe, or maybe set in the wrapper batch file only if /U flag is added.

Is there a way to specify additionnal flags to the command line that HTCondor is triggering, or do we need help from the developers there ?



Le 20/01/2016 19:20, Sean Milligan a Ãcrit :
> Mathieu,
> I also tried your batch file and then searched for the reason and a workaround. I found the reason but was unable to find a permanent workaround.
> Here are some links to explanations of the reason with the first one being the most concise:
> 	https://support.microsoft.com/en-us/kb/303308
> 	https://technet.microsoft.com/en-us/library/ee844140(v=ws.10).aspx - This one mentions a registry setting - I tried this and it didn't help under Condor but it did locally with an elevated command prompt.
> 	https://blogs.msdn.microsoft.com/cjacks/2007/02/19/mapped-network-drives-with-uac-on-windows-vista/
> 	https://support.microsoft.com/en-us/kb/937624
> The only workaround I found was to add the net use command into the batch file but I had to keep it in the file as commenting it out and submitting another job didn't restore access, so this could be shortened to not include the /persistent:yes option.
> 	net use s: \\fileserver\share /persistent:yes

tel : +33 (0)6 87 30 83 59
HTCondor-users mailing list
To unsubscribe, send a message to htcondor-users-request@xxxxxxxxxxx with a
subject: Unsubscribe
You can also unsubscribe by visiting

The archives can be found at: