[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [condor-users] examples won't compile [CC and F77 fixed, C++ still fails]

Hi all,

Well it does work on my system 
(pentium4 1800 MHz suse 8.2 512MB ram asus p4b533 mobo condor 6.6 gcc (GCC) 
3.3 20030226 )
Both vanilla, standard and java work.
I only tried a java program and a C program (no c++ nor fortran etc)
i compile the C programs with:
condor_compile gcc -o prog prog.c -Wl,--start-group -lc -lnss_files -lnss_dns 
-lresolv -Wl,--end-group

It does give a warning about "the use of `tmpnam' is dangerous, better use 
`mkstemp' " but it compiles ok.

Hope this helps a little.
So far i am pretty happy with condor, it takes a few moments to get all the 
options right for your first job to run, but in the end it does work!

Kind regards,

> On Wednesday 31 March 2004 13:05, Christian Rosenbleck wrote:
> Hello Ed,
> I saw that you are having problems using condor_compile with Suse Linux.
> Did you have any luck getting it to work? We have installed condor 6.6.1
> on several SuSE 8.1 and 9.0 machines, but condor_compile won't work, so
> we can't use the "Standard" universe.
> Thanks in advance!
> Christian
> On 03/26/2004 03:32 PM, Ed Kapitein wrote:
> > Hi all,
> >
> > I am very new at condor.
> > I tried to condor_compile the examples in the example directory.

Condor Support Information:
To Unsubscribe, send mail to majordomo@xxxxxxxxxxx with
unsubscribe condor-users <your_email_address>