[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Condor-users]question on Windows

> I just downloaded condor-6.6.10-winnt50-x86.exe and read the
> condor-V6_6_10-Manual.pdf.
> I found that Condor Version 6.6.10 supported platforms include Windows
> 2000 Professional and Server, 2003 Server (Win NT) on page 6 in the 
> manual But not including Windows XP.However,on page 309 manual tells 
> me that Condor for Windows requires Windows 2000 (or better) or Windows
> XP.
> I want to know whether Condor on Windows XP can run as the Central 
> Manager?

Yes it can - I'm running it right now on my machine.

> I run condor-6.6.10-winnt50-x86.exe on the machine whose platform is
> Windows2000 Server.

> The configuration of Condor follwed by GUIbased setup program are :
> Creating a New pool ...
> Name of the pool : BIT ASR
> hostname : condor_0
> release dir : C:\Condor
> email : asr2004@xxxxxxxxxx
> domain : asr.bit.edu.cn
> Access permissions:
>   Read : asr.bit.edu.cn
>   Write : asr.bit.edu.cn
>   Administrator : condor_0
> Between configing Condor and installing Condor(copy files),my computer
> prompt "The service cannot be installed due to an unknow error", then 
> installation continues.

That *sounds* bad, but if the collector is actually running it must've been installed somehow.  If you go to Control Panel -> Administrative Tools -> Services, do you see "Condor" in the list?  Does the user you installed Condor as have Administrative privileges?

> After installion,I run the command "condor_status"
> the result is "Error: could not fetch ads----can't find collector"
> "condor_q" the result is "-- Failed to fetch ads from: 
> <> : bit-bc0040dde1d "
> I check in the Task Manager , condor_collector is running .
> Now how can solve this problem ?

You may have a permissions problem.  Above, your "Read" and "Write" permissions are set to one machine (asr.bit.edu.cn) while it seems that the machine you're on is named "condor_0".  Since "condor_0" doesn't have read/write permissions it can't talk to itself.  You probably want more relaxed permissions, perhaps *.bit.edu.cn would be appropriate?

I'm also wondering about the actual name of the machine.  You say it's condor_0 (your answer to "hostname") but the output of condor_q mentions "bit-bc0040dde1d"...what's that?

You may want to take a look at the following:

Host-based security in Condor:

Installing Condor on Windows:
http://condor.optena.com/x/jQY (yes this is a shameless plug for http://condor.optena.com :-) )

Mike Yoder
Principal Member of Technical Staff
Ask Mike: http://condor.optena.com
Direct  : +1.408.321.9000
Fax     : +1.408.321.9030
Mobile  : +1.408.497.7597

Optena Corporation
2860 Zanker Road, Suite 201
San Jose, CA 95134