[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] I have 4 jobs being held in the queue andnothingis running because of that

Thank you very much for your help, you are my savior right now... 
Am I doing something wrong here, should I run this expression from a
different directory maybe the c:\condor\bin? I tried your suggestion
from two different systems, one being my computer , the second one the
central manager and the response is the same.  When I used single
quotation the error is "OpSys is not recognized" and if I used them the
error is "was unexpected at this time", please read the messages below.

C:\Condor>condor_status -const (OpSys == "WINNT52" || OpSys ==
"WINNT51") && (Arch == "INTEL") && (Disk >= DiskUsage) && ((Memory *
1024) >= ImageSize) && (HasFileTransfer) && (HasWindowsRunAsOwner &&
(LocalCredd =?= "Mann.earthdata.com"))
condor_status: unknown host ==
'OpSys' is not recognized as an internal or external command,
operable program or batch file.

C:\Condor>condor_status -const '(OpSys == "WINNT52" || OpSys ==
"WINNT51") && (Arch == "INTEL") && (Disk >= DiskUsage) && ((Memory *
1024) >= ImageSize) && (Has
FileTransfer) && (HasWindowsRunAsOwner && (LocalCredd =?=
' was unexpected at this time.
-----Original Message-----
From: condor-users-bounces@xxxxxxxxxxx
[mailto:condor-users-bounces@xxxxxxxxxxx] On Behalf Of Ian Chesal
Sent: Thursday, February 26, 2009 5:52 PM
To: Condor-Users Mail List
Subject: Re: [Condor-users] I have 4 jobs being held in the queue
andnothingis running because of that

> WARNING:  Be advised:
>   No resources matched request's constraints
>  Check the Requirements expression below:
> Requirements = (OpSys == "WINNT52" || OpSys == "WINNT51") && (Arch ==
> "INTEL") &
> & (Disk >= DiskUsage) && ((Memory * 1024) >= ImageSize) &&
> (HasFileTransfer) &&
> (HasWindowsRunAsOwner && (LocalCredd =?= "Mann.earthdata.com"))

> Is there another way to resubmit that job. I really don't get why is
> rejecting the job due to the requirements if the other jobs previous
> this one were able to run just fine?

There are no machines in your pool that match that job's requirements.
Maybe after the power outage the machine(s) that were previously
matching this requirement didn't come back up? You can search for
machines that match thing requirement by doing:

condor_status -const '(OpSys == "WINNT52" || OpSys == "WINNT51") &&
(Arch ==  "INTEL") && (Disk >= DiskUsage) && ((Memory * 1024) >=
ImageSize) && (HasFileTransfer) && (HasWindowsRunAsOwner && (LocalCredd
=?= "Mann.earthdata.com"))'

You need to look up what DiskUsage and what ImageSize are for your job
and substitute the actual value into that constraint string before you
do the call though.

If that call returns nothing you've got no matching machines.

You can also try the -better-analyze option -- it'll break down the
requirements string and show you precisely which component is keeping
you from matching any machines with your jobs. Only works on Linux

Hope that helps!

- Ian

Confidentiality Notice.
This message may contain information that is confidential or otherwise
protected from disclosure. If you are not the intended recipient, you
are hereby notified that any use, disclosure, dissemination,
distribution,  or copying  of this message, or any attachments, is
strictly prohibited.  If you have received this message in error, please
advise the sender by reply e-mail, and delete the message and any
attachments.  Thank you.

Condor-users mailing list
To unsubscribe, send a message to condor-users-request@xxxxxxxxxxx with
subject: Unsubscribe
You can also unsubscribe by visiting

The archives can be found at: