[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [HTCondor-users] change to condor_submit - user feedback desired! (was Re: multiple condor_submit's - one cluster)



On Mon, 9 Feb 2015, Dimitri Maziuk wrote:

On 02/09/2015 05:41 PM, Carl Edquist wrote:
...
1. I think the queue foreach <filepattern> idea (or similar, like #4819) is a great idea -- very natural and convenient syntax, whether for advanced users or not.

I think it should be "for i in <list>" and how you make the list is a separate question. When you consider that one, you'll get to

Sure, that makes sense. And I don't have a strong preference about the syntax; I just meant I was in general support of Todd's ideas 1 & 2, and that I didn't think they were mutually exclusive.

So maybe you could build your list with something like

	queue for FILE in <*.dat>

for globs, and one of

	queue for INPUT_LINE in listfile.txt

	queue for INPUT_LINE in -

for a list file on disk or from stdin. That seems natural enough to me, but I'm guessing everyone will have a different opinion about syntax... (Sorry Todd that you have to sort through them all.)

2_ Being able to _specify_ a list file, whether stdin or a file on disk, to supply an $(input_line) variable seems pretty nice to me

Of course. File like "job <name> <submit file>\nvars <name> foo=bar...", that sort of thing?

No I just meant each line in the list file would populate $(INPUT_LINE) (or whatever variable you pick) for that particular job.

Having multiple variables per line is an interesting idea too... It's more than I would ask for, but if I wanted to implement it, I'd probably do something like

	queue for V1,V2,V3 in listfile.txt

and have V1,V2,V3 be populated by whitespace-delimited fields from each line in listfile.txt, the last variable (V3) getting the remainder of the line if there are more than 3 fields. (Like the 'read' builtin in the shell.) ... That way giving only a single INPUT_LINE variable still gets the whole line.

...Todd now has enough proposals to go start his own bikeshed company... *shrug*

Carl


--
Dimitri Maziuk
Programmer/sysadmin
BioMagResBank, UW-Madison -- http://www.bmrb.wisc.edu