[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [HTCondor-users] what is connect errno=111

On 03/14/2017 02:54 PM, Todd L Miller wrote:
>     However, I also noticed that your lsof only shows UDP listen
> sockets.  I'm not quite sure how you arranged that -- shared port only
> works over TCP -- but I'm guessing that's the actual problem.  (You may
> also need to adjust your firewall.)

I didn't arrange anything, condor did it all to itself. This
worked in 8.2 with tcp updates not defined as per earlier thread ("node
gone from condor_status"). Then

> [root@exocet ~]# condor_config_val update_collector_with_tcp

and all 8.6 worker nodes including self (this machine has a couple of
cores set up to execute certain jobs) talked to it happily.

Now with 8.6.1, same config, same everything: collector won't bind to
tcp port 9618, nothing's listening on tcp 9618, and it won't talk over
udp even to itself even after setting UPDATE_COLLECTOR_WITH_TCP=FALSE.

Commenting out the 2 SHARED_PORT lines above fixed it for the local
pool. We'll have to deal with glidein later.
Dimitri Maziuk
BioMagResBank, UW-Madison -- http://www.bmrb.wisc.edu

Attachment: signature.asc
Description: OpenPGP digital signature