[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [condor-users] problem with Java execution

Java execution problem partially solved.
your and indirectly Matt's suggestion brought me to checking user
permissions and StarterLog, and there it was, where was the problem.
StarterLog says:
perm::init: Lookup Account Name condor-reuse-vm1 failed (err=1332), using
and there weren't any permisions specified for user Everyone, so when Condor
used user Everyone, it didn't have permission to acces java.exe and jvm.cfg.
(I installed Condor, not as an administrator, but as user which is in
Administrators group, but that shouldn't make any difference.)

I set read permission for Everyone on C drive and write on temp directory
and when I run my script which calls java.exe, it executes ok now.

However, Condor still doesn't detect that I have java installed on master
machine. What is the test, that it startd carries out to find if Java is
installed or not ? If it tries to write anything to disk, it fails, as on my
computer, Everyone has write permission only in temp directory.

BTW: I wouldn't use MS java either. When you install JRE 1.4 it cunningly
puts copy of java.exe to c:\winnt\system32\.


> > It is. It points to:
> > JAVA = c:\winnt\system32\java.exe
> Check that ALL have at least "read" permissions to this directory and
> this file. startd invokes java as a temporary user, and the fact that
> you can invoke it doesn't mean that startd can.
> In addition, I would not use Microsoft java, whatsoever.

Condor Support Information:
To Unsubscribe, send mail to majordomo@xxxxxxxxxxx with
unsubscribe condor-users <your_email_address>