[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] Problem with DLLs

I've been experimenting with this and I have got my application working at least
by setting the USERPROFILE env var (can be a junk value it doesn't matter).
Whether this is a panacea for other win xp apps I doubt it. Although
it does fit in with the other postings regarding apps accessing the
user's profile. This is the reasoning I followed:

1. Got Condor to run jobs under my username, accessing the same file
  files as I use interactively, on my PC. Doesn't work.

2. Captured all of my env vars and put them in .bat file so that they
  are all set before the app runs under condor. Works fine.

3. Deleted env vars one by one until job no longer runs. Found that
  only USERPROFILE needs to be set.

4. Run Condor job under its default username (condor-reuse-vm1). Still
  works OK - so is there anything special about the profile ?

5. Set USERPROFILE to junk value. Job still runs OK.

6. Put in all of the file staging so application files are now copied to the
  condor execute dir. Everything fine.

7. Run job on the "real" production pool rather than own PC. Things still
  work - time to go for a beer :->

I was interested in the comments regarding Matlab and Cygwin. I tried
to get Matlab compiled standalone apps to work for ages without much
success. Accessing the run time libs (the MCR as Matlab call it) from
a Novell server worked fine but I had problems accessing the actual
standalone app. As you are no doubt aware this isn't a monolithic
.exe but whole bundle of files stored hierarchically in directories.

I zipped these up and initially unzipped them using the Cygwin uzip
(needed to stage the Cygwin DLL as well) but kept getting the
"Access Denied" error. The files where unzipped OK but there was
just something that windoze didn't like about them. When I unzipped
them using a standard zip .exe program everything worked fine.
Very, very strange !



PS gory Matlab details available at:


--On 27 April 2006 10:04 +0100 "MD Tyka, Biochemistry" <M.Tyka@xxxxxxxxxxxxx> wrote:


thanks for all the replies, at least some new things to try :)

just for the record: we managed to get one of the apps (python.exe,
requiring python24.dll) to work: on some machines msvcr71.dll was needed
on top of the python dll - unfortunately the error message doesn't go
to stderr.

using a  batch wrapper around their exe. Some crazy users also had some
success  using Cygwin this way to!
Ah - this is exactly what we're trying to do. we have a ported app that
compiles very well under cygwin. our condor pool does not have cygwin
installed but we found that supplying cygwin1.dll solves that problem for
about half of our condor pool. The other half crashes the app with the
symptoms mentioned in the prev. posts. This is what i find so hard to
understand - the condor installations appear identical across the pool as
far as we can tell. I will try to look at the env variables to see if
there's any difference...



--On 26 April 2006 15:02 +0100 Patrick Townsend
<patrick.townsend@xxxxxxxxxxxxx> wrote:

We've had problems with some off-the-shelf apps requiring a fuller user
profile than Win32 Condor provides - try getting a Condor job to return
env  variables (set > set.txt) to see an example of the reduced
environment. We  never solved this one and now discourage our users from
trying it :-( For  more notes on this matter search this lists archives
for posts from my  colleague 'SG Wilkinson' - there are six in March and
April 2005.

We do have compiled Matlab working fine in this manner though. Matlab
DLLs  are accessed from a RO network share Condor jobs can connect to
using a  batch wrapper around their exe. Some crazy users also had some
success  using Cygwin this way to!


--On 26 April 2006 14:34 +0100 "Dr Ian C. Smith"
<i.c.smith@xxxxxxxxxxxxxxx> wrote:

--On 26 April 2006 12:42 +0100 "Dr Ian C. Smith"
<i.c.smith@xxxxxxxxxxxxxxx> wrote:

Incidently I'm seeing exactly this problem when I try to run SRB
clients using Condor. Empty stdout and stderr and the same logfile
message as you. When I run the same .exe's under my own account (which
is non-priviledged) it's fine. Bizarre !

I meant that when I run them *interactively* they work. When I change
the VM1_USER attribute to run the condor job under my account (with a
previously stored cred) they fail as well.

Condor-users mailing list

Patrick Townsend  -  Computer Support
Electrical  &  Electronic Engineering
MVB room 4.27   University of Bristol
www.bris.ac.uk     Tel: 0117 954 5288
email: patrick.townsend@xxxxxxxxxxxxx
Condor-users mailing list

Michael Tyka, Computational Protein Folding
C.62, Department of Biochemistry,
University of Bristol
Condor-users mailing list